How to disable Airplay on Yosemite 10.10.1 - Hackintosh Yosemite - Hackintosh Zone Jump to content
  • 0
neostyles

How to disable Airplay on Yosemite 10.10.1

Question

How to disable Airplay on Yosemite 10.10.1

Hey all, 
I have a Yosemite 10.10.1 and I was wondering if there was a way to disable airplay so I don't keep seeing my neighbors devices as audio outputs.   Thanks in advance! Any ideas would be appreciated!

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

To disable AirPlay
Open terminal and write
sudo chmod 000 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent

To enable AirPlay again
Open terminal and write
sudo chmod 755 /System/Library/CoreServices/AirPlayUIAgent.app/Contents/MacOS/AirPlayUIAgent

On a special side note: if you are ever planning on updating to El Capitan or Sierra (or anyone who has the same question and is on El Capitan or Sierra), the above commands only work when you disable SIP.

SIP should be disabled within your bootloader. If it's not the case you can do it by booting into Single User Mode (bootflag -s).

While in Single User Mode:

To disable SIP
Write "csrutil disable"
Reboot

To enable SIP again
Write "csrutil enable"
Reboot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting December 2017

    Please donate to support the community.
    We appreciate all donations!



    $32.14 of $100.00 goal reached.
    Donate Now
×