• 0
sekicz

GTX260 and working drivers

Question

GTX260 and working drivers

Hello,
I am kind of new in mac business but I think I am advanced user in computers technologies...
I am trying to get OS X working on my old machine its AMD (i know right lol) Phenom II X4 940, 4GB of RAM and at last point Gainward GTX260 896mb.
At the moment I am running Niresh`s Maverics successfully updated to 10.9.5 (13F34). I use MacPro3,1 in SMBios. OS X shows my graphics as Nvidia Chip Model 3MB
However, with my knowledge I am not able to get graphics acceleration working.
GraphicsEnabler=Yes won`t get my system started.
I installed the system only with /amd64 and the installation went fine.
But I keep getting that black / no signal error. 
Only thing how to get OS X load is to backup grafix kexts or use nv_disable=1.
So I downloaded nvidia web drivers and installed them with no problem at all, but it helped nothing... I changed to nvidia web driver in nvidia driver manager which also shows in ECC section no devices at any slot... Then I tried booting with nvda_drv=1 but it is all the same...
I know it is kinda odd - this combination AMD and 260 but I want to give it a shot and do not give up easily...
Thank you for all answers...

 

image.jpeg

Share this post


Link to post
Share on other sites

13 answers to this question

  • 0

Can you boot with "-v GraphicsEnabler=Yes PCIRootUID=1" and post a picture of the output?

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

The output is, that OS X loaded in FullHD with my 260 loaded in Nvidia manager... But I am facing problem, that my computer freezes after while when I want to restart it...

I suppose just to add PCIRoot and Graphics enabler in chameleon wizard? I tried only 720p video, but lauchpad and effects are working great.

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, sekicz said:

The output is, that OS X loaded in FullHD with my 260 loaded in Nvidia manager... But I am facing problem, that my computer freezes after while when I want to restart it...

I suppose just to add PCIRoot and Graphics enabler in chameleon wizard? I tried only 720p video, but lauchpad and effects are working great.

So, your graphics are working now? And indeed, you can select these options in Chameleon wizard. 

What do you mean with "computer freezes after a while when you want to restart it"?  Your computer is not restarting? Try the Restart Fix option in Chameleon. 

Share this post


Link to post
Share on other sites
  • 0

Yes it is working like a charm, i tried PCIRootUID once before but it didn`t work either, but now it works so thank you very much.

Yeah, i click restart in system, the circle keep spinning for a while and then it freezes cant turn on num-lock or anything. I didn`t notice the restart fix, so i will try it. Last question, is it safe to update the chameleon bootloader just like that from wizard app from system?

Share this post


Link to post
Share on other sites
  • 0

Yes you can update it from within Chameleon Wizard. You still have your installer USB, right? So, if anything goes wrong you can always use your installer USB to boot your OS X :wink:

Share this post


Link to post
Share on other sites
  • 0

Well I dont know, since i installed some updates for itunes and safari etc and now my pc restarts after showing bootflags in verbose mode...

image.png

Share this post


Link to post
Share on other sites
  • 0

What happens if you try bootflag -f ?

Share this post


Link to post
Share on other sites
  • 0

Could not get better screen. I guess some kext was replaced after updates, honestly I dont really know how many updates were there.

image.png

Share this post


Link to post
Share on other sites
  • 0

It has something to do with the kernel. Please try -x to see if booting into safe mode is possible.

Share this post


Link to post
Share on other sites
  • 0

I try to copy my backup kernel from updating to 10.9.5

sorry, my ipad is bugging on this page lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now