Clean install of Yosemite wont reboot - Hackintosh Yosemite - Hackintosh Zone Jump to content
  • 0
sekicz

Clean install of Yosemite wont reboot

Question

Hello,

so i get my basics together at Maverics but i had some problems with updates of Maverics and AMD kernels so I moved on to Yosemite.

And the problem is that my computer will never reboot even at end of the installation. The loading circle just freezes and I cant move my mouse or turn off numlock...

I have reboot fix checked in chameleon wizard but it does not help.

PC specs:

AMD Phenom II X4 940

ASUS Crosshair II Formula

4GB ram

Gainward GTX260

thanks for your help and cheers

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

But Yosemite is installed and you can boot into it, right? You can not reboot from within the installed Yosemite? Try EvoReboot from here

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Yep, I found the EvoReboot and it works perfectly. 

Now I am back at Mavericks again, reboot, graphics and everything is working very well. (I had some troubles at Yosemite with graphics..) 

Now I am just struggling with icloud and imessages (i dont mention iTunes which stopped working after update to 12.12 version) - where I think I am stuck somewhere between invalid s/n and using chameleon as a bootloader - i have read that its better to use Clover but i dont have UEFI mb so idk. Everymac.com recognised my s/n as mac pro 4,1 but apple check says that it is not valid. I guess that i will have to try few generated keys (from chameleon wizard) tomorrow again, since the apple check thing has limited number of check per day i guess.

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, sekicz said:

Yep, I found the EvoReboot and it works perfectly. 

Now I am back at Mavericks again, reboot, graphics and everything is working very well. (I had some troubles at Yosemite with graphics..) 

Now I am just struggling with icloud and imessages (i dont mention iTunes which stopped working after update to 12.12 version) - where I think I am stuck somewhere between invalid s/n and using chameleon as a bootloader - i have read that its better to use Clover but i dont have UEFI mb so idk. Everymac.com recognised my s/n as mac pro 4,1 but apple check says that it is not valid. I guess that i will have to try few generated keys (from chameleon wizard) tomorrow again, since the apple check thing has limited number of check per day i guess.

When Apple says that it isn't a valid serial number it is a good thing. If it says that it's a valid number, it means that someone else registered that number already :D Clover works on legacy BIOS too. Just make sure that you install the legacy bootloader.

Share this post


Link to post
Share on other sites
  • 0

I thought that it has to say that it is valid but not registered... anyway i don't know how to move to get the iCloud working lol

Share this post


Link to post
Share on other sites
  • 0
On 25-2-2017 at 7:32 PM, sekicz said:

I thought that it has to say that it is valid but not registered... anyway i don't know how to move to get the iCloud working lol

iCloud should work, I've never had problems with iCloud. In chameleon Wizard check "PCI Root = 1" and "EthernetBuiltIn = Yes". Reboot and iCloud should work. Just make sure your ethernet is set to en0:
cmd + spacebar -> "System Profiler" -> Network
 

Share this post


Link to post
Share on other sites
  • 0

By the way, I have iMessage working on Enoch/Chameleon, so you don't really NEED Clover to get it working, but with Clover it will be easier.

Share this post


Link to post
Share on other sites
  • 0

I tried to install kiresh Yosemite with clover standart but I could not really get it working. 

At the moment I am running Yosemite 10.10.1 with web drivers with FullHD running, but It still have some issues..

1. Finder is bugging somehow and I couldnt find any how-to solve it... Problem is when I open Finder that I cant click any folders or apps. I must hold left-click and mark something and open with right-click or two-click after I mark it, which is very annoying. Marking on desktop is working normally.

2. There was a problem with authorization of this Mac. When I wanted to log onto iCloud. MacPro4,1 in SMBios with week and random number filled in. I guess I will have to try more S/Ns. my ethernet port is eth0 and builtin. //realized that i forgot NVRam so i will give it a shot.

3. Graphics on log-in screen is messed up somehow (see the picture). Also Safari is a bit glitchy (Chrome is working fine...) - I cant load the youtube at all. I`d say graphics is little glitchy at all because even in chrome I have problems with fonts even when Chrome can play 1080p and 1440p videos with no problem...

17035781_1764368543580726_151861223_o.jpg

17036842_1764368470247400_549707011_o.jpg

Share this post


Link to post
Share on other sites
  • 0

1. Maybe a problem with the kernel. See below.

2. Nah, Apple does not check your serial per se, but hardware credentials within your NVRAM. I've always had iCloud and App Store working as long as I had EthernetBuiltIn and PCIRoot=1 checked. 

3. I believe the Yosemite AMD kernel has some bugs regarding to Graphics. Open terminal and write "kextstat | grep nvidia". If the kexts contain "web", then you are on the Nvidia web drivers. If not, then you are on the OS X default driver:
Schermafbeelding 2017-02-27 om 13.06.14.png

Can you update to 10.10.3 or 10.10.4? If so, try this kernel (make sure you put the kernel on your Yosemite zone install USB though, cuz you won't be able to boot after updating. So, after you updated, boot into your installer, open terminal and copy over the kernel to your harddrive).

Share this post


Link to post
Share on other sites
  • 0

Can I use this kernel on 10.10.5 or only .3 .4?

 

//// Kernel is located in S/L/Kernels? Since I have only kernel.backup there and the amd kernel is just folder Kernels and kernel file in it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $80.78 of $100.00 goal reached.
    Donate Now
×