Elitebook 8460P Hackintosh Boot-loader not Working - Hackintosh Sierra - Hackintosh Zone Jump to content
  • 0
Sign in to follow this  
wendytime

Elitebook 8460P Hackintosh Boot-loader not Working

Question

Elitebook 8460P Hackintosh Bootloader not Working

Just installed Sierra on my 8460p, i5 2520 HD3000, 4gb of RAM

Im having a lot of trouble trying to make everything work, first of all, I can't even boot from HD I need the USB stick every time, whenever I boot from UEFI Clover I get a circle with a crossed line, verbose shows something about "couldn't find cache".

Clover EFI folder is empty, no kexts, no sddt patches, nothing at all. Of course on the installer I select "Install Clover UEFI".

If I boot from the USB stick, I can get into the OS but only things working are ethernet,trackpad and keyboard, graphics card gets recognized as HD 3000 with only 3m of memory, resolution is low, no hardware acceleration, brightness keys not working, sound keys work but I get no sound.

On the installer I select

  • Clover UEFI
  • SMBIOS MAcbookPro 8.1

everything else I let as default.

Everything on this computer was working fine on El Capitan and Mavericks which I still have installed on a spare HD.

Help appreciated, I'm losing my patience after 2 days of fighting.

  • Like 1

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

If you can navigate into EFI folder, why don't you copy the contents of Sierra Zone's EFI folder to your Hard disk's EFI folder?

Your question title is no working kexts, but in the question you didn't mention anything about Kexts

Share this post


Link to post
Share on other sites
  • 0

yeah sorry for the misleading title, it was really late and tired of trying to make this work.

 

Ok a quick summary.. my HD died, so i got a new one, decided to jump straight into Sierra now that im at it. After installation, it goes smooth, but when it finishes and laptop restarts, if i unplug the Sierra Zone USB theres no Clover boot screen, only an HP logo.

I can boot with the Sierra Zone USB just fine, but whenever i try to install the latest Clover it gives an error, if i try to use Clover configurator to mount EFI partition it says it cant mount it, i can see it in Diskutil but it wont mount, i then installed Yosemite Zone this morning and now i cant boot from HD either, i can see the EFI partition and Clover folder but Clover bootloader just wont show up on the bootscreen.

What could i be doing wrong? im selecting "Install Clover EFI" on both Sierra and Yosemite Zone installer. Should i be selecting "Clover UEFI" instead? its like the EFI partition gets damaged somehow, i even completely formatted the HD on my Windows machine just in case the partition table got corrupted but still my EFI partition refuses to work, so i cant install kexts to Clover.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Are you booting sierra zone installer with UEFI Clover or EFI Clover?

Try selecting Sierra Zone with Do not install Bootloader selected, After installing boot into macOS with Sierra Zone USB, then download and Install Clover manually

Notes:

Sierra Zone formats EFI as hfs if you're installing Clover or Chameleon as EFI boot-loader

Sierra Zone formats EFI as MSDOS if you're installing Clover as UEFI boot-loader

To mount EFI Partition

mkdir /Volumes/EFI
diskutil list # Check with the list and replace disk0s1 with appropriate number

#for UEFI
mount_msdos /dev/disk0s1 /Volumes/EFI 

#for EFI
mount_hfs /dev/disk0s1 /Volumes/EFI 

 

Share this post


Link to post
Share on other sites
  • 0

Yeah i think thats the problem i had, EFI partition was nuked after every install therefore Clover gave me errors when installing manually.

 

Anyways, i started all over from scratch, used Niresh Yosemite and installed Clover as UEFI, from there i went to vanilla El Capitan using Clover and it went fine.

My question now is... can i just install Sierra Zone over vanilla El Capitan without ereasing the drive but just as an update? of course i should NOT install any kexts or system files.

 

EDIT: what model should i select in SMBIOS? on EL Capitan i had Macbook Air i believe... but cant find that one in Sierra zone installer.

Share this post


Link to post
Share on other sites
  • 0

Well... finally goodnews, installed fresh Sierra Zone and now i have everything working fine, just one last question.

 

Can i update to 10.12.4 from the Appstore? i want it for Night Shift, but i dotn want to break anything if i do update.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting December 2017

    Please donate to support the community.
    We appreciate all donations!



    $32.14 of $100.00 goal reached.
    Donate Now
×