• 0
SirSqays

Mouse & Keyboard not working

Question

Mouse & Keyboard not working

I boot to installer sierra but mouse and keyboard not working.

I applied this fix but still not working, boot arg: Kernel=amd -v npci=0x2000 UseKernelCache=No (without this not starting).I plug to usb2.0/3.0. flag USBBusFix It also does not work

PC spec:

  • AMD FX 4130
  • MSI 970A-G43
  • GTX 750

 

1 person likes this

Share this post


Link to post
Share on other sites

9 answers to this question

  • 0

Wow you have tried most of the possible options, but where did you placed the USB FIx kexts that you downloaded from the above link ?

I can assume that USB is working because you're in the Installer, i still wonder why USB Keyboard is not working, did you spot anything unusual in the verbose log?

Did you try to boot from clover?

Share this post


Link to post
Share on other sites
  • 0

i put usb fix to /System/Library/Extensions and kernel to /System/Library/Kernel without this fixes not booting.

Keyboard working partially (numpad not working).

Mouse The light is on but the cursor does not move.

In -v everything is ok.

How to boot clover? Default boot in enoch.

Share this post


Link to post
Share on other sites
  • 0

This is an issue which i can't reproduce, sometimes -x can fix this, can you attach a video while booting with -v

Try this fix to bypass language chooser 

To boot Clover, after choosing USB as boot device keep pressing Number 6

@SirSqays

Share this post


Link to post
Share on other sites
  • 0

@Niresh When i tried clover not booting with this 

-x flag don't work.

Video from -v 

 

Share this post


Link to post
Share on other sites
  • 0

Im seeing issues related to XHCI in the verbose log, try removing the following kexts and try boot from USB

/Volumes/Hackintosh Sierra Zone/System/Library/Extensions/FakePCIID_XHCIMux.kext
/Volumes/Hackintosh Sierra Zone/System/Library/Extensions/FakePCIID.kext

To fix the clover related issue delete OsxAptioFix2Drv-64.efi from the Clover folder, keep me updated @SirSqays

Share this post


Link to post
Share on other sites
  • 0

@Niresh When im delete this kext's keyboard fully working (with numpad) but mouse still not. The laser works but the cursor does not. (In enoch)

Clover boot totally not working keyboard and mouse 

 

Share this post


Link to post
Share on other sites
  • 0

Clover will not work because clover depends on Prelinked Kernel "Technically Kernel Cache". To rebuild kernel cache just plug your USB into a machine that already runs sierra and reboot macOS, macOS will take care of the rest.

but Chameleon doesn't need KernelCache, UseKernelCache=No is a Chameleon boot flag, will not work with Clover.

You have installed USB Kexts from "Sierra AMD Kernel & USB Fix" those kexts aren't native kexts,  i advice you to make a fresh Sierra Zone Image with transmac and then remove the following kexts

/Volumes/Hackintosh Sierra Zone/System/Library/Extensions/FakePCIID_XHCIMux.kext
/Volumes/Hackintosh Sierra Zone/System/Library/Extensions/FakePCIID.kext

@SirSqays Keep me posted.

Share this post


Link to post
Share on other sites
  • 0

I created fresh install deleted this kext and it work keyboard and mous is ok but on install i have errors nvidia.pkg when unchecked this i have audio.pkg error.

Installer Log:

https://pastebin.com/C86Atuhs

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

In the installer log you provided it says Audio.pkg is causing the error, better unselect Auto Install Audio driver and Backup Graphics Extensions (3 Packages) in the customize section

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now