ALC887 not working/detected - Sound Kexts - Hackintosh Zone ALC887 not working/detected Jump to content
teemo

ALC887 not working/detected

Recommended Posts

ALC887 not working/detected

I set up a Hackintosh for the first time and it took a while to set up. I got everything to work EXCEPT for sound. I tried to installations, but when I run the command file, it says no audio device detected. On clover bootloader, under audio, it says "Unknown HDA device". My audio device is Realtek ALC887. Any help would be appreciated. @Niresh

My system: 

  • Intel i3 6100 3.7 Ghz
  • Nvidia GTX 750 Ti
  • MSI H110m Pro-D motherboard
  • Windows 10 Home - Toshiba 1tb HDD 7200rpm NTFS
  • Macintosh Sierra - WD Green 750gb HDD 5400rpm HFS+

Share this post


Link to post
Share on other sites

Open terminal & run the following command post the output here

sudo lspci -nn

Have you tried installing AppleALC.kext, now AppleALC.kext requires Lilu.kext Install both and let me know the results

If it doesn't work remove AppleALC.kext and Lilu.kext then install VoodooHDA.kext check if it is working 

Get back to me with the results @teemo

  • Like 1

Share this post


Link to post
Share on other sites

@Niresh

Hi, I tried the first method but it did not work. I also tried VoodooHDA but when I try to access it, it says "No VoodooHDA Devices Detected". I tried to run that command but I get the following: "sudo: lspci: command not found". Any ideas?

Share this post


Link to post
Share on other sites

@teemo Download and Install LSPCI, then run the command post results

How did you install macOS Sierra?

Share this post


Link to post
Share on other sites

@Niresh

Okay when I run lspci after installing it, I get: 

Mehtabs-iMac:~ mehtabmahir$ sudo lspci -nn
Password:
DirectHW.kext not loaded.
lspci: Cannot find any working access method.
Mehtabs-iMac:~ mehtabmahir$ 

First time I installed the hackintosh.zone version (audio still didnt work), then I made an official vanilla apple installation through app store and installed that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $53.73 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Hello everyone,  I'm trying to install High Sierra (with AMD support) on my AMD 4500m Lenovo G505s laptop. When booting from Clover in EFI with i get some really fast screen log then the pc reboots. Now, i know there isn't a way you could help me without some info/logs, unless i'm missing a major malfunction known on these kind of laptops, so, do you know a way i could prevent it from rebooting in order to at least understand what is causing this problem? Do you think even trying to put OSX on this laptop is worth it? Thank you.
    • Hello, i am trying to install High Sierra on my ASUS X75VB but i am getting multiple errors with the ACPI.
      I believe it is CPU related?

      Mainboard: HM76 (X75VB SOCKET 0)
      CPU: Intel Core i5 3320m (Not the original CPU of this laptop!)
      GPU: Intel HD Graphics 4000 & NVIDIA 2GB Geforce 740M
      RAM: DDR3 8GB
      Storage: 120GB SSD (SATA-2)

      I have used the DSDT.aml & SSDT.aml from the following resource:
       https://github.com/xxx10101xxx/ThinkPad-X230-macOS/tree/master/i5-3320M

      My config.plst can be found here:
      https://drive.google.com/open?id=1lK7ixY8fAvtIJv8gY6Gf-RQvKJBVcFLm

      Thanks in advance!
    • im already download 10.12 and 10.13 . when im trying install 10.12 . all works fine , like resolution already 1920x1080 , sound , network all fine .. but when im trying install 10.13. resolution wont 1080 , already install nvidia web drivers , but hopeless..

      using Nvidia GT630 , btw .
    • I have Yosemite Zone working on Virtualbox fine.  After downloading High Sierra Zone there is only a dmg and no ISO.  I tried converting the dmg with hdiutil but it goes to 8GB and I get "no bootable media" in Virtualbox.  Has anyone been able to do this yet? 
  • Download Statistics

    • Files
      849
    • Comments
      2,144
    • Reviews
      2,627

    Latest File
    By ka209

    116    0

×