no bless setting for a primary boot program was found - Hackintosh Sierra - Hackintosh Zone no bless setting for a primary boot program was found Jump to content
mdg1618

no bless setting for a primary boot program was found

Recommended Posts

no bless setting for a primary boot program was found


Hello:

I had Yosemite 10.10.5 installed on my PC (PC specifications are noted below) via "Niresh's Yosemite with AMD & Intel ISO & USB" and everything ran well.

Recently, I tried to upgrade to Sierra OS via "Hackintosh Sierra Zone", but ran into some problems. I rechecked my BIOS settings and everything was OK and I also checked (verified) my SSD, which was also OK.

During the booting of my system, I use the flags:
cpus=1 npci=0x3000 nv_disable=1
which allows me to get to the install screen, where I am able to access Disk Utility to erase my SSD.

Afterwards, I use the "Customize" button within the macos installer to install needed drivers and kexts (I have tried to install Sierra OS without changing any of the settings as well).

At last, I press the "Continue" button within the macos installer and after a couple of seconds, I get a message:
"no bless setting for a primary boot program was found"

I searched the forum and found a similar problem and deleted "OsxAptioFix2Drv-64.efi" from: HZ/EFI/CLOVER/drivers64UEFI using Windows 10, because I did not know how to do it in the terminal.

Even after the deletion of "OsxAptioFix2Drv-64.efi" I still receive the message "no bless setting for a primary boot program was found". I also tried to install Sierra OS onto my system by utilizing different USB ports on my PC.

I have searched for common boot flags to alleviate this problem and I have searched the Web as well with no solution found until now.

 

Thank you in advance for your assistance towards this matter.

 

PC Specifications:
MoBo: Asus Rampage IV Black Edition (BIOS:0602 x64)
CPU: Intel i7-4930K
GPU: PNY Geforce GTX 780 Ti 3072MB OC
Memory: 4 x 4GB Corsair Dominator Platnium 16GB (4 x 4GB) DDR3 DRAM 2133MHz C8
PSU: Super Flower 1000W
CPU Cooler: Cooler Master Nepton 280l
System Drive: Samsung 840 Pro - 128 GB SSD
Storage Drive: 2 x Seagate Barracuda 7200.14 ST3000DM001 3TB - 7200 RPM 64MB Cache

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $148.22 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Affter install High Sierra Zone in: Gigabyte H110m / i3 7100 In first reboot working the graphics but no USB drivers / External USB disks i cant mount clover In the secod reboot have problem, the solution -disiablegfxfirmware ane boot whit config, but hace the same problems, dont see the usb drivers and can not mount uefi partition In other reboot see diferentes config, i try diferents, boot with config_uefi without flags, but when run the graphics dont works but i see the usb drivers and external disk and mount the uefi driver. how repair this? boot with config and fix everting or boot with config_uefi and fix graphics?   sorry my inglis is not god
    • Dear Guys,
      Im trying to install mac os x sierra in my dell laptop and ihave followed all the details and reached the installation part. But im getting error saying "An error occurred installing macOS.To use apple diagnostics to check your mac hardware"
      Guys please please help me with it.ithink im almost 90% close to installing mac os. my lap config as follows.the person who help me resolve will be my hero  Motherboard: INTEL i3 370M 2.40GHZ,0KRP5X CPU: DELL N4030 MODEL. Graphics: ATI Mobility Radeopn HD 5430 Motherboard:  
    • i did one but no hdmi or display port sound even if they are detected processor neither no wifi   and install a multiboot ? i triyed clover but didnt work    
    • Hey can some one help me with a problem https://ibb.co/jv8TRT this is my problem I hope you can help me guys
    • Hi
      I followed Nirav's High Sierra installation guide.
      My problem is that I am getting the below error at the install boot screen (osxAptioFix2Drv:Starting overrides for System\Library\CoreServices\boot.efi
      Using reloc block: no hibernate wake: no)


      what I should to do?

      my specs:
      Asus Rampage VI Extreme 
      intel Core i7 7800x
      Samsung 960 EVO SSD 250 
      Gigabyte GEFORCE GTX 1080 TI Gaming OC
      GSkill TridentZ DDR4 8x2 GB
  • Download Statistics

    • Files
      849
    • Comments
      2,144
    • Reviews
      2,627

    Latest File
    By ka209

    122    0

×