Stuck at waiting for root device (Niresh Sierra). - Hackintosh Sierra - Hackintosh Zone Jump to content

Recommended Posts

Stuck at waiting for root device (Niresh Sierra).

Hello Guys,
I am trying to install niresh sierra using chameleon bootloader and 
got error message waiting for root device and it stuck there.
i have niresh yosemite in my laptop and wants to upgrade it to sierra, 
Already tried some boot flags like USBBusFix=Yes, CPUS=1, but no change in error.
you can have look at error snapshot here  :->
please help me out. 

Share this post

Link to post
Share on other sites

Usually USBBusFix=Yes is enough,  I'm sorry i didn't read your question completely that was my mistake, I'm replying from my iPhone. When you boot from USB keep pressing number 6 that will load clover bootloader try booting Sierra from Installation with Clover, what is your Laptop model you didn't post your hardware details. If possible post images of your BIOS USB Settings 

  • Like 1

Share this post

Link to post
Share on other sites

Sorry for not posting my laptop details.
I have Asus Laptop model no. K53SD. with Intel Core i3 2.29 Ghz 2nd Gen Processor, 4 GB 1333 MHz DDR3 Ram, Intel HD 3000 Graphics 384 MB.(Sandy Bridge).
i already have your yosemite with chameleon installed so i just want it to upgrade to sierra.(As i am unable to install Xcode in current OS).
if i boot sierra with clover then, can i upgrade previous yosemite..

Thank you for making this much effort and taking time to answer my questions. 

Share this post

Link to post
Share on other sites

Yes you can upgrade but fresh installation is recommend
i still wonder why Yosemite works and Sierra stuck at waiting for Root device?
Did you try booting from clover

  • Like 2

Share this post

Link to post
Share on other sites

No, i have not tried booting with clover, but i am going to give a try now.
and i have some different error previously which is giving kernel panic error
and backtrace was pointing to AppleIntelCpuPowerManagement
so i replaced it with my patched AICPM in usb image. and that error was solved but this error pops up.

Share this post

Link to post
Share on other sites

i have the same problem...asus a55v i7 8 giga ram 750 g hd...i have install yosemite without problem..with sierra zone a have the same message..if i want to install sierra with clover what is the procedure?i press the number 6 on key on startup but i have the same menu..

Share this post

Link to post
Share on other sites

same problem here... stuck at waiting for root device ...

though i've tried everything but no luck...

booted from all the usb ports lead to the same error..

booted from both the legacy and clover lead to the same error...

tried bootflags : -v -x -F -f -s USBBusFix=Yes

lead to the same error...

only once i'd booted it bypassing the error and go to the apple logo but a cross sign appeared on the screen - installation stopped.

But i had successfully installed yosemite zone...

never had an error or problem at yosemite installation...

so what is the problem in Sierra zone ???

please fix this error, please...  @Niresh

Toshiba satellite pro laptop config :

processor : i3-3110 M cpu @ 2.40 ghz

Ram : 4 gb

Graphics : Intel HD 4000

Bios : Insyde H2O

Ethernet : QC AR8161 pci-e 

wireless : Qc AR9565

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!

    $48.99 of $120.00 goal reached.
    Donate Now