Sierra - no bless setting for a primary boot program was found - Hackintosh Sierra - Hackintosh Zone Jump to content
mdg1618

Sierra - no bless setting for a primary boot program was found

Recommended Posts

Sierra - no bless setting for a primary boot program was found

Hello:

I had Yosemite 10.10.5 installed on my PC (PC specifications are noted below) via "Niresh's Yosemite with AMD & Intel ISO & USB" and everything ran well.

Recently, I tried to upgrade to Sierra OS via "Hackintosh Sierra Zone", but ran into some problems. I rechecked my BIOS settings and everything was OK and I also checked (verified) my SSD, which was also OK.

During the booting of my system, I use the flags:
cpus=1 npci=0x3000 nv_disable=1
which allows me to get to the install screen, where I am able to access Disk Utility to erase my SSD.

Afterwards, I use the "Customize" button within the macos installer to install needed drivers and kexts (I have tried to install Sierra OS without changing any of the settings as well).

At last, I press the "Continue" button within the macos installer and after a couple of seconds, I get a message:
"no bless setting for a primary boot program was found"

I searched the forum and found a similar problem and deleted "OsxAptioFix2Drv-64.efi" from: HZ/EFI/CLOVER/drivers64UEFI using Windows 10, because I did not know how to do it in the terminal.

Even after the deletion of "OsxAptioFix2Drv-64.efi" I still receive the message "no bless setting for a primary boot program was found". I also tried to install Sierra OS onto my system by utilizing different USB ports on my PC.

I have searched for common boot flags to alleviate this problem and I have searched the Web as well with no solution found until now.

 

Thank you in advance for your assistance towards this matter.

 

PC Specifications:
MoBo: Asus Rampage IV Black Edition (BIOS:0602 x64)
CPU: Intel i7-4930K
GPU: PNY Geforce GTX 780 Ti 3072MB OC
Memory: 4 x 4GB Corsair Dominator Platnium 16GB (4 x 4GB) DDR3 DRAM 2133MHz C8
PSU: Super Flower 1000W
CPU Cooler: Cooler Master Nepton 280l
System Drive: Samsung 840 Pro - 128 GB SSD
Storage Drive: 2 x Seagate Barracuda 7200.14 ST3000DM001 3TB - 7200 RPM 64MB Cache

  • Like 1

Share this post


Link to post
Share on other sites

Hello Niresh,

Thank you for your reply.

I did not change the SMBIOS, it is still set for iMac 14,2.

Share this post


Link to post
Share on other sites

i am also having the same issue with my installation on g61m gigabyte motherboard, previously running el captian. 

one thing to note that i tried the same installation with any another 500gb seagate harddisk, its showing random issue with different package files, 
like audio.pkg, network.pkg, dart0.pkg respectively after unselecting one by one from customize menu.

Share this post


Link to post
Share on other sites

Hello Ashishdadhich,

Sorry to hear that? Did you get your system up and running yet?

I got mines up and running, but I had to download and install Niresh Yosemite on my system at first. After that I downloaded Sierra OS X from Hackintosh Zone and then made a bootable Sierra USB using Disk Utility.

After that my system would only boot with the USB plugged in, so I had to copy my EFI folder from my USB and replaced it with the one on my disk drive (mounted both drives on the desktop using clover configurator) and now all works well.

I hope that this helped you, if not please feel free to comment. I will do my best to be of service although I am also new at this.

Share this post


Link to post
Share on other sites

Hello mdg1618,

thanks for your reply, but i am still trying to install sierra on my computer, let me try to follow your way with yosemite first, i will let you know how it works.

 

thanks again.

Share this post


Link to post
Share on other sites
On 16/04/2017 at 5:53 AM, Niresh said:

Did you change the SMBIOS?

Hi Niresh,

Do you know a fix for the ''No Bless Setting For A Primary Boot Program Was Found''? I have tried several times install the sierra zone and always the same error.

My computer is a toshiba P755-103, runs the Yosemite zone very well.

best regards,

 

Share this post


Link to post
Share on other sites

Had the same problem but i solved it by changing the bootloader in the settings before the installation. Hope this helps, regards. Bill Gates

  • Like 1

Share this post


Link to post
Share on other sites
On 7/14/2017 at 5:44 PM, BillGates said:

Had the same problem but i solved it by changing the bootloader in the settings before the installation. Hope this helps, regards. Bill Gates

couldve just changed the hard drive you want to install the mac os on to primary boot in your bios

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hello, friends, I need your help. I am using  Motherboard: Asus H81M-CS Processor:  Intel Core i3-4130 Graphics: Intel HD Graphics 4400 I connected monitor via VGA port.   Everything is working great. Only issue right now I am having is graphics with VGA Port. Can any one suggest me to solve this issue?
    • It's because when you update, the kernel is replaced & so are the kexts. You need to either know how to use Terminal to copy the files after booting into your USB OR hook up your Start Disk Hard Drive to another Hack or Mac & copy over the proper kernel to System/Library/Kernels/ & also use kextwizard to install the kexts required as well & then repair cache. It's not that complicated if you have another Mac or Hack(intosh) to connect your drive to. There are some tutorials online. I'm by no means a pro at this at all, but I couldn't believe no one had replied to anyone here. I'm actually in the exact same situation, just finished updating my Yosemite Zone 10.10 to 10.10.5 through AppStore & it won't boot back in, then I remembered when I did this last time I had to connect my HD to another mac & copy over files, but I can't remember exact files so I came here to look for them & found this thread. I have been successful in getting an old MSI Platinum35 mobo with the 771/775 mod & Xeon x5460 with AMD 6850 running Sierra. I have been successful getting a newer MSI A88XM Gaming Mobo with x4 760k & AMD 6670 running Mavericks, then Yosemite, then High Sierra, and recently tested Sierra & it worked too. One thing though is that with Sierra & High Sierra the screen flickered different colors & I needed to download a thing called SwitchResZ & change the setting from "Billions of Colors" to "Millions of Colors" & it fixed it both times, even after I uninstalled it, the screen flickering was gone,.. So I have been through a few different processes (not including the updates like 10.10 to 10.10.5) But I am the farthest thing from a pro. Just followed tutorials, googled  & used distros, I think DeeKay was first one for Mavericks, then Yosemite Zone, Sierra Zone, & finally High Sierra Zone. But my digi 002r worked on all with the AVID 003 family 11.1.3 driver, except when it came to high sierra. For some reason it has sync issues with Midi/audio. Says something about not recognizing clock speed of 43,121Khz or something (cuz it should be 44.1Khz, or 48Khz etc) But it only happens on High Sierra. On Yosemite I had to do a trick cuz the play bar's timing was off, to fix it I went into bios & changed my multiplier from 100 to 103 so instead of my cpu running at 3.6Ghz, it was like 3.9Ghz. But for some reason that fixed it & Yosemite was stable, rarely (if ever) did it crash. But Sierra crashes all the time so I can't make music on it anymore, for some reason I don't think it was like this at first...maybe something I installed. Only reason why I changed was to keep up with Logic X updates. My Sierra build is up to date with Logic X 10.4 & Digi 002r runs great (11.1.3 driver) but like I said it crashes alot & I don't know why. So my thought was to return to Yosemite 10.10 & update to 10.10.5 like I did b4 & downgrade Logic X to 10.3 or 10.2.4(can't remember). So I got to find those files & instructions again to put the proper kernel & texts back that the update erased. That's what ya'll need to do as well. When I find it I will come back & edit my post or just post a new one.
    • Hai,

      Is there a way to increase video memory of a 

      AMD A4-6210 APU

      AMD Radeon R3 Graphics 1.8 Ghz

      it is not for gaming, but only to seen movies ect
    • So I tried to install Mac OS X Sierra on my computer with the following specs :   - Intel Core i5 650 3.20GHZ - 12GB RAM DDR3 - 2 HDD (.1TB , 250GB ) - Nvidia Geforce 210 1GB VRAM DDR3   Everything was cool at first the installation went smoothly with no problems, after setting up everything I noticed that the graphics card has been detected by the systems but there is no acceleration and the resolution is 1024x768, I couldn’t change it   I tried a lot of kext drivers from multiple websites but no success, last kext crashes my os, I start getting black screen after the login page, and the computer restart it self immediately, so I decided to mess with the clover options to find if I can enable the graphics card from there, and WALLAA, the magic happened, I went to clover options then > Graphics Injector Menu > I checked : InjectNvidia option, and I checked : Use NVIDIA WEB Drivers   Note : I already installed Nvidia web drivers previously so you do that too before trying this method   After the restart it took longer then the usual to boot up, but once it got to the login page I noticed that the acceleration is working perfectly and the graphics has no bugs like before.   So until now everything is working fine and I’m enjoying my experience with Mac Sierra  
    • HI, I have the same issue. I have integrated Intel HD4000 and nVidia 620m. I tried with IGPEnabler, GraphicsEnabler and nv_disabled bootflags but none of them helped, it just got me additional kernel panic "AppleUSBHostPort: :disconnect: persistant enumeration failures". I also don't have option to turn off any of my graphic cards in BIOS.  Is there any solution to this issue?
  • Download Statistics

    • Files
      848
    • Comments
      2,135
    • Reviews
      2,568

    Latest File
    By Vale1831

    5    0

×