Intel HD4000 acceleration - Graphics Kexts - Hackintosh Zone Jump to content

Recommended Posts

Hi everyone, 

 

I have an HP laptop with Optimus technology (HP Sleekbook 15 - Ivy bridge HD4000 + GeForce 630M) on which I managed to run Niresh 10.9 but I still got a problem. Needless to say, I can't disable the GeForce from BIOS like on most laptops.

In order to successfully boot in mavericks, I had to remove all the graphic kext files from S/L/E (either Intel, ATI and Geforce), so I can now boot with GraphicsEnabler=Yes. Of course now my system recognises the HD4000 but only with 64M of shared memory and the graphics is kinda buggy. 

I tried to install the HD4000 graphics kexts for mavericks from the download section, but when I do it, I can't boot anymore (black screen). I don't know if that happens because the OS tries to use the GeForce chip or because it needs something else. 

Are there any other kext files that I need to install in order to have a full functional graphics (either using the Intel or the Nvidia chip) ? 

 

Cheers

 

Share this post


Link to post
Share on other sites
Deepak    1,701

add a flag SkipnvidiaGFX=yes in org.chamleon.plist reinstall you hd4000 kexts and use appropriate SMBIOS 

  • Like 12

Share this post


Link to post
Share on other sites

add a flag SkipnvidiaGFX=yes in org.chamleon.plist reinstall you hd4000 kexts and use appropriate SMBIOS

Thanks Deepak. I'm trying it now but it isn't working. Which hd4000 kext did you mean? The original ones that I removed after installing or the modified ones available in the download section? And how do I find out which SMBIOS would be more appropriate for my hardware?

Share this post


Link to post
Share on other sites
Deepak    1,701

just only find AppleintelFramebuffercapri.kext  may it will in extra/backup folder 

  • Like 13

Share this post


Link to post
Share on other sites

Tried it, also using different smbios, but I still get a black screen. So far I tried with Macpro3,1Macmini5,1Macmini6,1MacbookPro6,1 (I've used multibeast) Anything else I can try?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hi guys, managed to make a hackintosh and everything is going great (Wifi, cpu ECT)   But it's pretty damn slow, i tried one of my favorite lightweight games to test (The Ultimate Doom) and it could barely run THAT! This is my first time and i have no idea how to get my 8570 to work.. Probably should have read a bit, eh? Lol.   And no I don't plan on using my hackintosh for gaming, but god so slow..   Thanks, help would be very appreciated. Edit: It's the dedicated version btw, and in about my mac I see "Graphics Display 3 MB" maybe the issue?  
    • Trying to boot to the installer but I get instant reboot after the following: I am using the following flag (I tried a variation - I need USBBusFix=Yes otherwise it fails even earlier): All my USB devices turn off just before it reboots, so I'm guessing it loses connection to the USB install media - but I can't work out why it's disabling all the USB's. CPU: AMD FX 8350 (8-core)
      RAM: 12GB HyperX Fury
      Motherboard: AsRock Fatal1ty 990FX Killer
      GPU: Gigabyte 4GB NVIDIA GTX 960
    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×