Reboot instead of shutdown - Hackintosh Sierra - Hackintosh Zone Jump to content
  • 0
Sign in to follow this  
coords

Reboot instead of shutdown

Question

coords    0
Reboot instead of shutdown

Does anyone have any idea what I can do to prevent my machine from rebooting when I try to shut it down? Thank!!

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
coords    0

Please guys, I'm sure someone here has the answer to this :)

Share this post


Link to post
Share on other sites
  • 0

Can you shut down the machine through the terminal using this command:

sudo shutdown –h now

It may prompt you for confirmation after putting this command in, but it may work.

If you're wanting to put it into a script that you can run without having to remember the command:

echo "#!/bin/bash" > shutdown.sh
echo "shutdown -h now" >> shutdown.sh
chmod 777 shutdown.sh

To call that script:

sudo ./shutdown.sh

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
coords    0

The script seemed to work, but sadly exactly the same result. The machine seems to shutdown but actually reboots. An extremely annoying bug since I manager this machine headless via my iOS devices.

Share this post


Link to post
Share on other sites
  • 0
15 hours ago, coords said:

The script seemed to work, but sadly exactly the same result. The machine seems to shutdown but actually reboots. An extremely annoying bug since I manager this machine headless via my iOS devices.

Okay so I may have found the answer from insanelymac regarding the same issue with Yosemite (which seems to be an issue with Clover bootloader and the motherboard being used)

 

Quote

You can try this setings

<key>Fixes</key>
<dict>
        <key>FixShutdown_0004</key>
        <true/>
</dict>

or

<key>SlpSmiAtWake</key>
<true>

It adds SLP_SMI_EN=0 at every wake. It may help solve sleep and shutdown issues on UEFI boot.

Those settings have to be added to your /EFI/CLOVER/config.plist file if they're not already in there.

I haven't tested these since Yosemite doesn't seem to have shutdown issues, but some members on that thread were saying that adding one of those settings to their config.plist file helped with their power issue.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
coords    0

thanks for your reply!! Sadly my machine has a bios & this setting is not applicable as far as I know. Any other suggestions would be welcome!!

On 5/24/2017 at 2:25 PM, KimChoJapFan said:

Okay so I may have found the answer from insanelymac regarding the same issue with Yosemite (which seems to be an issue with Clover bootloader and the motherboard being used)

 

Those settings have to be added to your /EFI/CLOVER/config.plist file if they're not already in there.

I haven't tested these since Yosemite doesn't seem to have shutdown issues, but some members on that thread were saying that adding one of those settings to their config.plist file helped with their power issue.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $22.65 of $100.00 goal reached.
    Donate Now
×

Important Information

By using this site, you agree to our Terms of Use.